F5 Networks BIG-IP : BIND vulnerability (SOL13660)

High Nessus Plugin ID 86003

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

ISC BIND 9.x before 9.7.6-P1, 9.8.x before 9.8.3-P1, 9.9.x before 9.9.1-P1, and 9.4-ESV and 9.6-ESV before 9.6-ESV-R7-P1 does not properly handle resource records with a zero-length RDATA section, which allows remote DNS servers to cause a denial-of-service (DoS) (process crash or data corruption) or obtain sensitive information from process memory by way of a crafted record. (CVE-2012-1667)

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution SOL13660.

See Also

https://support.f5.com/csp/article/K6963

http://www.isc.org/downloads/BIND/

http://www.nessus.org/u?5424fea4

https://support.f5.com/csp/article/K13660

Plugin Details

Severity: High

ID: 86003

File Name: f5_bigip_SOL13660.nasl

Version: 2.7

Type: local

Published: 2015/09/18

Updated: 2019/01/04

Dependencies: 76940

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:f5:big-ip_access_policy_manager, cpe:/a:f5:big-ip_application_security_manager, cpe:/a:f5:big-ip_global_traffic_manager, cpe:/a:f5:big-ip_link_controller, cpe:/a:f5:big-ip_local_traffic_manager, cpe:/a:f5:big-ip_wan_optimization_manager, cpe:/a:f5:big-ip_webaccelerator, cpe:/h:f5:big-ip, cpe:/h:f5:big-ip_protocol_security_manager

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/06/12

Reference Information

CVE: CVE-2012-1667

BID: 53772