Scientific Linux Security Update : spice-server on SL7.x x86_64

Medium Nessus Plugin ID 85790


The remote Scientific Linux host is missing one or more security updates.


A race condition flaw, leading to a heap-based memory corruption, was found in spice's worker_update_monitors_config() function, which runs under the QEMU-KVM context on the host. A user in a guest could leverage this flaw to crash the host QEMU-KVM process or, possibly, execute arbitrary code with the privileges of the host QEMU-KVM process. (CVE-2015-3247)


Update the affected spice-debuginfo, spice-server and / or spice-server-devel packages.

See Also

Plugin Details

Severity: Medium

ID: 85790

File Name: sl_20150903_spice_server_on_SL7_x.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2015/09/04

Modified: 2015/09/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2015/09/03

Reference Information

CVE: CVE-2015-3247