Tenable SecurityCenter Multiple Apache Vulnerabilities (TNS-2015-11)

medium Nessus Plugin ID 85628


The remote application is affected by multiple vulnerabilities.


The Tenable SecurityCenter application installed on the remote host contains a bundled version of Apache HTTP Server prior to 2.4.16. It is, therefore, affected by the following vulnerabilities :

- A flaw exists in the chunked transfer coding implementation in http_filters.c. due to a failure to properly parse chunk headers when handling large chunk-size values and invalid chunk-extension characters. A remote attacker can exploit this, via a crafted request, to carry out HTTP request smuggling, potentially resulting in cache poisoning or the hijacking of credentials. (CVE-2015-3183)

- A security bypass vulnerability exists due to a failure in the ap_some_auth_required() function in request.c to consider that a Require directive may be associated with an authorization setting instead of an authentication setting. A remote attacker can exploit this, by leveraging the presence of a module that relies on the 2.2 API behavior, to bypass intended access restrictions under certain circumstances.

Note that the 4.x version of SecurityCenter is impacted only by CVE-2015-3183. The 5.x version is impacted by both CVE-2015-3183 and CVE-2015-3185


Apply the relevant patch for version 4.7.1 / 4.8.2 as referenced in the vendor advisory. Alternatively, upgrade to Tenable SecurityCenter version 5.0.2.

See Also




Plugin Details

Severity: Medium

ID: 85628

File Name: securitycenter_apache_2_4_16.nasl

Version: 1.22

Type: combined

Agent: unix

Family: Web Servers

Published: 8/25/2015

Updated: 11/27/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2015-3183


Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Required KB Items: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 8/20/2015

Vulnerability Publication Date: 6/8/2015

Reference Information

CVE: CVE-2015-3183, CVE-2015-3185

BID: 75963, 75965