Tenable SecurityCenter Multiple Apache Vulnerabilities (TNS-2015-11)
Medium Nessus Plugin ID 85628
SynopsisThe remote application is affected by multiple vulnerabilities.
DescriptionThe Tenable SecurityCenter application installed on the remote host contains a bundled version of Apache HTTP Server prior to 2.4.16. It is, therefore, affected by the following vulnerabilities :
- A flaw exists in the chunked transfer coding implementation in http_filters.c. due to a failure to properly parse chunk headers when handling large chunk-size values and invalid chunk-extension characters. A remote attacker can exploit this, via a crafted request, to carry out HTTP request smuggling, potentially resulting in cache poisoning or the hijacking of credentials. (CVE-2015-3183)
- A security bypass vulnerability exists due to a failure in the ap_some_auth_required() function in request.c to consider that a Require directive may be associated with an authorization setting instead of an authentication setting. A remote attacker can exploit this, by leveraging the presence of a module that relies on the 2.2 API behavior, to bypass intended access restrictions under certain circumstances.
Note that the 4.x version of SecurityCenter is impacted only by CVE-2015-3183. The 5.x version is impacted by both CVE-2015-3183 and CVE-2015-3185
SolutionApply the relevant patch for version 4.7.1 / 4.8.2 as referenced in the vendor advisory. Alternatively, upgrade to Tenable SecurityCenter version 5.0.2.