Tenable SecurityCenter Alternative Certificate Validation Bypass Vulnerability (TNS-2015-08)

Medium Nessus Plugin ID 85565


The remote application is affected by a certificate validation bypass vulnerability.


The SecurityCenter application installed on the remote host is affected by a certificate validation bypass vulnerability in the bundled OpenSSL library. The library is version 1.0.1n or later and prior to 1.0.1p. It is, therefore, affected by a flaw in the X509_verify_cert() function that is triggered when locating alternate certificate chains in cases where the first attempt to build such a chain fails. A remote attacker can exploit this to cause certain certificate checks to be bypassed, resulting in an invalid certificate being considered valid.


Apply the relevant patch referenced in the vendor advisory.

See Also



Plugin Details

Severity: Medium

ID: 85565

File Name: securitycenter_openssl_1_0_1p.nasl

Version: 1.10

Type: local

Family: Misc.

Published: 2015/08/20

Modified: 2018/02/14

Dependencies: 71158

Risk Information

Risk Factor: Medium


Base Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N


Base Score: 7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Required KB Items: Host/SecurityCenter/Version, Host/local_checks_enabled

Patch Publication Date: 2015/07/20

Vulnerability Publication Date: 2015/07/09

Reference Information

CVE: CVE-2015-1793

BID: 75652

OSVDB: 124300