Debian DSA-3337-1 : gdk-pixbuf - security update

Medium Nessus Plugin ID 85517

Synopsis

The remote Debian host is missing a security-related update.

Description

Gustavo Grieco discovered a heap overflow in the processing of BMP images which may result in the execution of arbitrary code if a malformed image is opened.

Solution

Upgrade the gdk-pixbuf packages.

For the oldstable distribution (wheezy), this problem has been fixed in version 2.26.1-1+deb7u3.

For the stable distribution (jessie), this problem has been fixed in version 2.31.1-2+deb8u4.

See Also

https://packages.debian.org/source/wheezy/gdk-pixbuf

https://packages.debian.org/source/jessie/gdk-pixbuf

https://www.debian.org/security/2015/dsa-3337

Plugin Details

Severity: Medium

ID: 85517

File Name: debian_DSA-3337.nasl

Version: 2.4

Type: local

Agent: unix

Published: 2015/08/19

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gdk-pixbuf, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/08/18

Reference Information

CVE: CVE-2015-4491

DSA: 3337