Apache Tomcat JK Connector 1.2.x < 1.2.41 JkUnmount Directive Handling Remote Information Disclosure

medium Nessus Plugin ID 85513
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by an information disclosure vulnerability.

Description

Based on the Server response header, the installation of the JK Connector (mod_jk) in Apache Tomcat listening on the remote host is version 1.2.x prior to 1.2.41. It is, therefore, affected by an information disclosure vulnerability due to improper handling of the 'JkUnmount' directive and multiple, adjacent slashes in requests. A remote attacker can exploit this to access restricted private artifacts, resulting in the disclosure of sensitive information.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to mod_jk version 1.2.41 or later.

See Also

http://www.nessus.org/u?a336ab81

https://svn.apache.org/viewvc?view=revision&revision=1647017

Plugin Details

Severity: Medium

ID: 85513

File Name: mod_jk_1_2_41.nasl

Version: 1.3

Type: remote

Family: Web Servers

Published: 8/18/2015

Updated: 7/14/2018

Dependencies: http_version.nasl, find_service1.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat_connectors

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 12/20/2014

Vulnerability Publication Date: 12/20/2014

Reference Information

CVE: CVE-2014-8111

BID: 74265