GLSA-201508-02 : libgadu: Multiple vulnerabilities

High Nessus Plugin ID 85430


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201508-02 (libgadu: Multiple vulnerabilities)

libgadu contains multiple vulnerabilities:
X.509 certificates are not properly validated (CVE-2013-4488) A integer overflow error could lead to a buffer overflow (CVE-2013-6487) Malformed responses from a Gadu-Gadu file relay server are not properly handled (CVE-2014-3775) Impact :

A remote attacker may be able to execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or spoof servers.
Workaround :

There is no known workaround at this time.


All libgadu users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/libgadu-1.12.0'

See Also

Plugin Details

Severity: High

ID: 85430

File Name: gentoo_GLSA-201508-02.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2015/08/17

Modified: 2015/08/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libgadu, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2015/08/15

Reference Information

CVE: CVE-2013-4488, CVE-2013-6487, CVE-2014-3775

GLSA: 201508-02