Debian DSA-3325-1 : apache2 - security update

medium Nessus Plugin ID 85164
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been found in the Apache HTTPD server.

- CVE-2015-3183 An HTTP request smuggling attack was possible due to a bug in parsing of chunked requests. A malicious client could force the server to misinterpret the request length, allowing cache poisoning or credential hijacking if an intermediary proxy is in use.

- CVE-2015-3185 A design error in the 'ap_some_auth_required' function renders the API unusuable in apache2 2.4.x. This could lead to modules using this API to allow access when they should otherwise not do so. The fix backports the new 'ap_some_authn_required' API from 2.4.16. This issue does not affect the oldstable distribution (wheezy).

In addition, the updated package for the oldstable distribution (wheezy) removes a limitation of the Diffie-Hellman (DH) parameters to 1024 bits. This limitation may potentially allow an attacker with very large computing resources, like a nation-state, to break DH key exchange by precomputation. The updated apache2 package also allows to configure custom DH parameters. More information is contained in the changelog.Debian.gz file. These improvements were already present in the stable, testing, and unstable distributions.

Solution

Upgrade the apache2 packages.

For the oldstable distribution (wheezy), these problems have been fixed in version 2.2.22-13+deb7u5.

For the stable distribution (jessie), these problems have been fixed in version 2.4.10-10+deb8u1.

See Also

https://security-tracker.debian.org/tracker/CVE-2015-3183

https://security-tracker.debian.org/tracker/CVE-2015-3185

https://packages.debian.org/source/wheezy/apache2

https://packages.debian.org/source/jessie/apache2

https://www.debian.org/security/2015/dsa-3325

Plugin Details

Severity: Medium

ID: 85164

File Name: debian_DSA-3325.nasl

Version: 2.9

Type: local

Agent: unix

Published: 8/3/2015

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 4.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:apache2, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 8/1/2015

Reference Information

CVE: CVE-2015-3183, CVE-2015-3185

DSA: 3325