Debian DSA-3325-1 : apache2 - security update

Medium Nessus Plugin ID 85164


The remote Debian host is missing a security-related update.


Several vulnerabilities have been found in the Apache HTTPD server.

- CVE-2015-3183 An HTTP request smuggling attack was possible due to a bug in parsing of chunked requests. A malicious client could force the server to misinterpret the request length, allowing cache poisoning or credential hijacking if an intermediary proxy is in use.

- CVE-2015-3185 A design error in the 'ap_some_auth_required' function renders the API unusuable in apache2 2.4.x. This could lead to modules using this API to allow access when they should otherwise not do so. The fix backports the new 'ap_some_authn_required' API from 2.4.16. This issue does not affect the oldstable distribution (wheezy).

In addition, the updated package for the oldstable distribution (wheezy) removes a limitation of the Diffie-Hellman (DH) parameters to 1024 bits. This limitation may potentially allow an attacker with very large computing resources, like a nation-state, to break DH key exchange by precomputation. The updated apache2 package also allows to configure custom DH parameters. More information is contained in the changelog.Debian.gz file. These improvements were already present in the stable, testing, and unstable distributions.


Upgrade the apache2 packages.

For the oldstable distribution (wheezy), these problems have been fixed in version 2.2.22-13+deb7u5.

For the stable distribution (jessie), these problems have been fixed in version 2.4.10-10+deb8u1.

See Also

Plugin Details

Severity: Medium

ID: 85164

File Name: debian_DSA-3325.nasl

Version: 2.8

Type: local

Agent: unix

Published: 2015/08/03

Updated: 2020/09/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:apache2, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/08/01

Reference Information

CVE: CVE-2015-3183, CVE-2015-3185

DSA: 3325