Debian DSA-3325-1 : apache2 - security update
Medium Nessus Plugin ID 85164
SynopsisThe remote Debian host is missing a security-related update.
DescriptionSeveral vulnerabilities have been found in the Apache HTTPD server.
- CVE-2015-3183 An HTTP request smuggling attack was possible due to a bug in parsing of chunked requests. A malicious client could force the server to misinterpret the request length, allowing cache poisoning or credential hijacking if an intermediary proxy is in use.
- CVE-2015-3185 A design error in the 'ap_some_auth_required' function renders the API unusuable in apache2 2.4.x. This could lead to modules using this API to allow access when they should otherwise not do so. The fix backports the new 'ap_some_authn_required' API from 2.4.16. This issue does not affect the oldstable distribution (wheezy).
In addition, the updated package for the oldstable distribution (wheezy) removes a limitation of the Diffie-Hellman (DH) parameters to 1024 bits. This limitation may potentially allow an attacker with very large computing resources, like a nation-state, to break DH key exchange by precomputation. The updated apache2 package also allows to configure custom DH parameters. More information is contained in the changelog.Debian.gz file. These improvements were already present in the stable, testing, and unstable distributions.
SolutionUpgrade the apache2 packages.
For the oldstable distribution (wheezy), these problems have been fixed in version 2.2.22-13+deb7u5.
For the stable distribution (jessie), these problems have been fixed in version 2.4.10-10+deb8u1.