GLSA-201507-22 : e2fsprogs: Arbitrary code execution

medium Nessus Plugin ID 84974
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201507-22 (e2fsprogs: Arbitrary code execution)

e2fsprogs has a heap-based buffer overflow in closefs.c in the libext2fs library.
Impact :

A local attacker could execute arbitrary code via a specially crafted block group descriptor.
Workaround :

There is no known workaround at this time.

Solution

All e2fsprogs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-fs/e2fsprogs-1.42.13'

See Also

https://security.gentoo.org/glsa/201507-22

Plugin Details

Severity: Medium

ID: 84974

File Name: gentoo_GLSA-201507-22.nasl

Version: 2.2

Type: local

Published: 7/24/2015

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS v2.0

Base Score: 4.6

Temporal Score: 4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:e2fsprogs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/23/2015

Reference Information

CVE: CVE-2015-1572

BID: 72709

GLSA: 201507-22