VMware Workstation 10.x < 10.0.7 / 11.x < 11.1.1 DACL Privilege Escalation (VMSA-2015-0005)

High Nessus Plugin ID 84806


The virtualization application installed on the remote host is affected by a privilege escalation vulnerability.


The version of VMware Workstation installed on the remote host is 10.x prior to 10.0.7 or 11.x prior to 11.1.1. It is, therefore, affected by a privilege escalation vulnerability due to a failure to provide a valid discretionary access control list (DACL) pointer for the printproxy.exe process. A local attacker, using thread injection, can exploit this to gain elevated privileges or execute arbitrary code.


Upgrade to VMware Workstation version 10.0.7 / 11.1.1 or later.

See Also


Plugin Details

Severity: High

ID: 84806

File Name: vmware_workstation_priv_esc_vmsa_2015_0005.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2015/07/16

Modified: 2016/05/22

Dependencies: 26201

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: SMB/Registry/Enumerated, VMware/Workstation/Version, VMware/Workstation/Path

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/09

Vulnerability Publication Date: 2015/07/09

Reference Information

CVE: CVE-2015-3650

BID: 75686

OSVDB: 124364

VMSA: 2015-0005