VMware Horizon View Client 5.x < 5.4.2 DACL Privilege Escalation (VMSA-2015-0005)

High Nessus Plugin ID 84804


The virtualization application installed on the remote host is affected by a privilege escalation vulnerability.


The version of VMware Horizon View Client installed on the remote host is 5.x (with local mode) prior to 5.4.2. It is, therefore, affected by a privilege escalation vulnerability due to a failure to provide a valid discretionary access control list (DACL) pointer for the printproxy.exe process. A local attacker, using thread injection, can exploit this to gain elevated privileges or execute arbitrary code.


Upgrade to VMware Horizon View Client 5.4.2 (with local mode) or later.

See Also


Plugin Details

Severity: High

ID: 84804

File Name: vmware_horizon_view_client_vmsa_2015_0005.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2015/07/16

Modified: 2015/07/17

Dependencies: 76964

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:horizon_view_client

Required KB Items: SMB/Registry/Enumerated, installed_sw/VMware Horizon View Client

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/09

Vulnerability Publication Date: 2015/07/09

Reference Information

CVE: CVE-2015-3650

BID: 75686

OSVDB: 124364

VMSA: 2015-0005