OpenSSL 1.0.2 < 1.0.2d Multiple Vulnerabilities

Medium Nessus Plugin ID 84637


The remote host is affected by multiple vulnerabilities.


According to its banner, the remote host is running a version of OpenSSL 1.0.2 prior to 1.0.2d. It is, therefore, affected by the following vulnerabilities :

- A certificate validation bypass vulnerability exists due to a flaw in the X509_verify_cert() function in x509_vfy.c that is triggered when locating alternate certificate chains when the first attempt to build such a chain fails. A remote attacker can exploit this, by using a valid leaf certificate as a certificate authority (CA), to issue invalid certificates that will bypass authentication. (CVE-2015-1793)

- A race condition exists in s3_clnt.c that is triggered when PSK identity hints are incorrectly updated in the parent SSL_CTX structure when they are received by a multi-threaded client. A remote attacker can exploit this, via a crafted ServerKeyExchange message, to cause a double-free memory error, resulting in a denial of service. (CVE-2015-3196)


Upgrade to OpenSSL version 1.0.2d or later.

See Also

Plugin Details

Severity: Medium

ID: 84637

File Name: openssl_1_0_2d.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Web Servers

Published: 2015/07/09

Modified: 2017/07/20

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/07/09

Vulnerability Publication Date: 2015/07/09

Reference Information

CVE: CVE-2015-1793, CVE-2015-3196

BID: 75652

OSVDB: 124300, 131040