VMware Workstation 10.x < 10.0.6 / 11.x < 11.1.1 Multiple Vulnerabilities (VMSA-2015-0004) (Windows)

Medium Nessus Plugin ID 84223

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.4

Synopsis

The remote host has a virtualization application installed that is affected by multiple vulnerabilities.

Description

The version of VMware Workstation installed on the remote Windows host is 10.x prior to 10.0.6 or 11.x prior to 11.1.1. It is, therefore, affected by multiple vulnerabilities :

- An arbitrary code execution vulnerability exists due to a stack-based buffer overflow condition in the JPEG2000 plugin that is triggered when parsing a Quantization Default (QCD) marker segment in a JPEG2000 (JP2) image file. A remote attacker can exploit this, using a specially crafted image, to execute arbitrary code or cause a denial of service condition. (CVE-2012-0897)

- Multiple unspecified remote code execution vulnerabilities exists in 'TPView.dll' and 'TPInt.dll' library files. (CVE-2015-2336, CVE-2015-2337)

- The 'TPview.dll' and 'TPInt.dll' library files fail to properly handle memory allocation. A remote attacker can exploit this to cause a denial of service.
(CVE-2015-2338, CVE-2015-2339, CVE-2015-2340)

Solution

Upgrade to VMware Workstation version 10.0.6 / 11.1.1 or later.

See Also

http://www.vmware.com/security/advisories/VMSA-2015-0004.html

Plugin Details

Severity: Medium

ID: 84223

File Name: vmware_workstation_multiple_vmsa_2015_0004.nasl

Version: 1.10

Type: local

Agent: windows

Family: Windows

Published: 2015/06/16

Updated: 2018/08/06

Dependencies: 26201

Risk Information

Risk Factor: Medium

VPR Score: 7.4

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: SMB/Registry/Enumerated, VMware/Workstation/Version, VMware/Workstation/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/09

Vulnerability Publication Date: 2015/06/09

Exploitable With

Core Impact

Metasploit (Irfanview JPEG2000 jp2 Stack Buffer Overflow)

Reference Information

CVE: CVE-2012-0897, CVE-2015-2336, CVE-2015-2337, CVE-2015-2338, CVE-2015-2339, CVE-2015-2340

BID: 51426, 75092, 75095

VMSA: 2015-0004