VMware Player 6.x < 6.0.6 RPC Command DoS (VMSA-2015-0004) (Linux)

High Nessus Plugin ID 84221


The remote host has a virtualization application installed that is affected by a denial of service vulnerability.


The version of VMware Player installed on the remote Linux host is 6.x prior to 6.0.6. It is, therefore, affected by a denial of service vulnerability due to improper validation of user-supplied input to a remote procedure call (RPC) command. An unauthenticated, remote attacker can exploit this, via a crafted command, to crash the host or guest operating systems.


Upgrade to VMware Player version 6.0.6 or later.

See Also


Plugin Details

Severity: High

ID: 84221

File Name: vmware_player_linux_6_0_6.nasl

Version: $Revision: 1.9 $

Type: local

Family: General

Published: 2015/06/16

Modified: 2016/11/29

Dependencies: 71051

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:player

Required KB Items: Host/uname, Host/VMware Player/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/06/09

Vulnerability Publication Date: 2015/06/09

Reference Information

CVE: CVE-2015-2341

BID: 75094

OSVDB: 123094

VMSA: 2015-0004