VMware Player 6.x < 6.0.6 Multiple Vulnerabilities (VMSA-2015-0004)

High Nessus Plugin ID 84219


The remote host has a virtualization application installed that is affected by multiple vulnerabilities.


The version of VMware Player installed on the remote Windows host is 6.x prior to 6.0.6. It is, therefore, affected by multiple vulnerabilities :

- An arbitrary code execution vulnerability exists due to a stack-based buffer overflow condition in the JPEG2000 plugin that is triggered when parsing a Quantization Default (QCD) marker segment in a JPEG2000 (JP2) image file. A remote attacker can exploit this, using a specially crafted image, to execute arbitrary code or cause a denial of service condition. (CVE-2012-0897)

- Multiple unspecified remote code execution vulnerabilities exists in 'TPView.dll' and 'TPInt.dll' library files. (CVE-2015-2336, CVE-2015-2337)

- The 'TPview.dll' and 'TPInt.dll' library files fail to properly handle memory allocation. A remote attacker can exploit this to cause a denial of service.
(CVE-2015-2338, CVE-2015-2339, CVE-2015-2340)

- A denial of service vulnerability exists due to improper validation of user-supplied input to a remote procedure call (RPC) command. An unauthenticated, remote attacker can exploit this, via a crafted command, to crash the host or guest operating systems. (CVE-2015-2341)


Upgrade to VMware Player version 6.0.6 or later.

See Also


Plugin Details

Severity: High

ID: 84219

File Name: vmware_player_6_0_6_vmsa_2015-0004.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2015/06/16

Modified: 2016/11/29

Dependencies: 31728

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:vmware:player

Required KB Items: SMB/Registry/Enumerated, VMware/Player/Path, VMware/Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/09

Vulnerability Publication Date: 2015/06/09

Exploitable With

Core Impact

Metasploit (Irfanview JPEG2000 jp2 Stack Buffer Overflow)

Reference Information

CVE: CVE-2012-0897, CVE-2015-2336, CVE-2015-2337, CVE-2015-2338, CVE-2015-2339, CVE-2015-2340, CVE-2015-2341

BID: 51426, 75092, 75094, 75095

OSVDB: 78333, 123089, 123090, 123091, 123092, 123093, 123094

VMSA: 2015-0004