CUPS < 2.0.3 Multiple Vulnerabilities

High Nessus Plugin ID 84149


The remote printer service is potentially affected by multiple vulnerabilities.


According to its banner, the CUPS printer service running on the remote host is a version prior to 2.0.3. It is, therefore, potentially affected by the following vulnerabilities :

- A privilege escalation vulnerability exists due to a flaw in cupsd when handling printer job request errors.
An unauthenticated, remote attacker can exploit this, with a specially crafted request, to prematurely free an arbitrary string of global scope, creating a dangling pointer to a repurposed block of memory on the heap, resulting ACL verification to fail when parsing 'admin/conf' and 'admin' ACLs. This allows an attacker to upload a replacement CUPS configuration file.

- A cross-site scripting vulnerability exists due to improper sanitization of user-supplied input to the 'QUERY' parameter of the help page. This allows a remote attacker, with a specially crafted request, to execute arbitrary script code. (CVE-2015-1159)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to CUPS version 2.0.3 or later. Alternatively, apply the patch provided by the vendor.

See Also

Plugin Details

Severity: High

ID: 84149

File Name: cups_2_0_3.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2015/06/12

Modified: 2015/06/15

Dependencies: 10107, 29727

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/09

Vulnerability Publication Date: 2015/03/23

Reference Information

CVE: CVE-2015-1158, CVE-2015-1159

BID: 75098

CERT: 810572