CUPS < 2.0.3 Multiple Vulnerabilities

critical Nessus Plugin ID 84149
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote printer service is potentially affected by multiple vulnerabilities.


According to its banner, the CUPS printer service running on the remote host is a version prior to 2.0.3. It is, therefore, potentially affected by the following vulnerabilities :

- A privilege escalation vulnerability exists due to a flaw in cupsd when handling printer job request errors.
An unauthenticated, remote attacker can exploit this, with a specially crafted request, to prematurely free an arbitrary string of global scope, creating a dangling pointer to a repurposed block of memory on the heap, resulting ACL verification to fail when parsing 'admin/conf' and 'admin' ACLs. This allows an attacker to upload a replacement CUPS configuration file.

- A cross-site scripting vulnerability exists due to improper sanitization of user-supplied input to the 'QUERY' parameter of the help page. This allows a remote attacker, with a specially crafted request, to execute arbitrary script code. (CVE-2015-1159)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to CUPS version 2.0.3 or later. Alternatively, apply the patch provided by the vendor.

See Also

Plugin Details

Severity: Critical

ID: 84149

File Name: cups_2_0_3.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 6/12/2015

Updated: 11/22/2019

Dependencies: http_version.nasl, cups_1_3_5.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2015-1158


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/9/2015

Vulnerability Publication Date: 3/23/2015

Reference Information

CVE: CVE-2015-1158, CVE-2015-1159

BID: 75098

CERT: 810572