Oracle Linux 6 / 7 : docker (ELSA-2015-3037)

High Nessus Plugin ID 83776


The remote Oracle Linux host is missing one or more security updates.


Description of changes:

- Update source to 1.6.1 from Symlink traversal on container respawn allows local privilege escalation (CVE-2015-3629) Insecure opening of file-descriptor 1 leading to privilege escalation (CVE-2015-3627) Read/write proc paths allow host modification information disclosure (CVE-2015-3630) Volume mounts allow LSM profile escalation (CVE-2015-3631) AppArmor policy improvements


Update the affected docker packages.

See Also

Plugin Details

Severity: High

ID: 83776

File Name: oraclelinux_ELSA-2015-3037.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2015/05/22

Modified: 2015/12/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:docker, p-cpe:/a:oracle:linux:docker-devel, p-cpe:/a:oracle:linux:docker-fish-completion, p-cpe:/a:oracle:linux:docker-logrotate, p-cpe:/a:oracle:linux:docker-pkg-devel, p-cpe:/a:oracle:linux:docker-vim, p-cpe:/a:oracle:linux:docker-zsh-completion, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/05/21

Reference Information

CVE: CVE-2015-3627, CVE-2015-3629, CVE-2015-3630, CVE-2015-3631

BID: 74558, 74559, 74563, 74566