Oracle VM VirtualBox < 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 / 4.3.28 QEMU FDC Overflow RCE (VENOM)

high Nessus Plugin ID 83729
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has an application that is affected by a remote code execution vulnerability.

Description

The remote host contains a version of Oracle VM VirtualBox that is prior to 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 / 4.3.28. It is, therefore affected by a flaw in the Floppy Disk Controller (FDC) in the bundled QEMU software due to an overflow condition in 'hw/block/fdc.c' when handling certain commands. An attacker, with access to an account on the guest operating system with privilege to access the FDC, can exploit this flaw to execute arbitrary code in the context of the hypervisor process on the host system.

Solution

Upgrade Oracle VM VirtualBox to 3.2.28 / 4.0.30 / 4.1.38 / 4.2.30 / 4.3.28 or later.

See Also

http://www.nessus.org/u?2bd5df81

https://www.virtualbox.org/wiki/Changelog

http://venom.crowdstrike.com/

Plugin Details

Severity: High

ID: 83729

File Name: virtualbox_4_3_28.nasl

Version: 1.10

Type: local

Agent: windows

Family: Windows

Published: 5/20/2015

Updated: 8/6/2018

Dependencies: virtualbox_installed.nasl

Risk Information

VPR

Risk Factor: Critical

Score: 9.7

CVSS v2

Risk Factor: High

Base Score: 7.7

Temporal Score: 6.4

Vector: AV:A/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:vm_virtualbox, cpe:/a:oracle:virtualization

Required KB Items: VirtualBox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/15/2015

Vulnerability Publication Date: 5/13/2015

Exploitable With

Core Impact

Reference Information

CVE: CVE-2015-3456

BID: 74640

IAVA: 2015-A-0112