Rockwell Automation RSLinx Classic < 3.73.00 Buffer Overflow

critical Nessus Plugin ID 83523


An application running on the remote host is affected by an arbitrary code execution vulnerability.


The remote host has a version of RSLinx Classic installed that is prior to 3.73.00. It is, therefore, affected by an arbitrary code execution vulnerability due an overflow condition caused by improper validation of user-supplied input. A local attacker can exploit this, via a specially crafted comma-separated value (CSV) file, to cause a stack-based buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.


Upgrade to Rockwell Automation RSLinx Classic version 3.73.00 or later.

See Also

Plugin Details

Severity: Critical

ID: 83523

File Name: scada_rslinx_classic_3_73_00.nbin

Version: 1.89

Type: local

Agent: windows

Family: SCADA

Published: 5/18/2015

Updated: 9/25/2023

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Medium

Score: 6.5


Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2014-9204


Risk Factor: Critical

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:rockwellautomation:rslinx_classic

Required KB Items: installed_sw/Rockwell Automation RSLinx Classic

Exploit Ease: No known exploits are available

Patch Publication Date: 5/7/2015

Vulnerability Publication Date: 4/20/2015

Reference Information

CVE: CVE-2014-9204

BID: 74553

ICSA: 15-111-02