Rockwell Automation RSLinx Classic < 3.73.00 Buffer Overflow

High Nessus Plugin ID 83523


An application running on the remote host is affected by an arbitrary code execution vulnerability.


The remote host has a version of RSLinx Classic installed that is prior to 3.73.00. It is, therefore, affected by an arbitrary code execution vulnerability due an overflow condition caused by improper validation of user-supplied input. A local attacker can exploit this, via a specially crafted comma-separated value (CSV) file, to cause a stack-based buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.


Upgrade to Rockwell Automation RSLinx Classic version 3.73.00 or later.

See Also

Plugin Details

Severity: High

ID: 83523

File Name: scada_rslinx_classic_3_73_00.nbin

Version: $Revision: 1.22 $

Type: local

Family: SCADA

Published: 2015/05/18

Modified: 2018/01/29

Dependencies: 83522

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/a:rockwellautomation:rslinx_classic

Required KB Items: installed_sw/Rockwell Automation RSLinx Classic

Patch Publication Date: 2015/05/07

Vulnerability Publication Date: 2015/04/20

Reference Information

CVE: CVE-2014-9204

BID: 74553

OSVDB: 121094

ICSA: 15-111-02