ClamAV < 0.98.7 Multiple Vulnerabilities

Medium Nessus Plugin ID 83352

Synopsis

The antivirus service running on the remote host is affected by multiple vulnerabilities.

Description

According to its version, the ClamAV clamd antivirus daemon on the remote host is prior to 0.98.7. It is, therefore, affected by multiple vulnerabilities :

- An unspecified flaw exists in the pefromupx() function in upx.c. A remote attacker can exploit this flaw, via a specially crafted file, to crash the application.
(CVE-2015-2170)

- An unspecified flaw exists in the yc_poly_emulator() function in yc.c. A remote attacker can exploit this flaw, via a specially crafted y0da cryptor file, to cause an infinite loop and application hang.
(CVE-2015-2221)

- An unspecified flaw exists in the cli_scanpe() function in pe.c. A remote attacker can exploit this, via a specially crafted petite packer file, to crash the program. (CVE-2015-2222)

- An integer overflow condition exists in the bundled Henry Spencer regex library in the regcomp() function in regcomp.c due to improper validation of user-supplied input. A remote attacker can exploit this to cause a buffer overflow, resulting in a denial of service or the execution of arbitrary code. (CVE-2015-2305)

- An unspecified flaw exists when handling specially crafted xz archive files. A remote attacker can exploit this to cause an infinite loop. (CVE-2015-2668)

Solution

Upgrade to ClamAV 0.98.7 or later.

See Also

http://blog.clamav.net/2015/04/clamav-0987-has-been-released.html

Plugin Details

Severity: Medium

ID: 83352

File Name: clamav_0_98_7.nasl

Version: 1.8

Type: remote

Family: Misc.

Published: 2015/05/12

Updated: 2018/07/06

Dependencies: 39436

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:clamav:clamav

Required KB Items: Antivirus/ClamAV/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/04/29

Vulnerability Publication Date: 2015/02/04

Reference Information

CVE: CVE-2015-2170, CVE-2015-2221, CVE-2015-2222, CVE-2015-2305, CVE-2015-2668

BID: 72611, 72611, 74472

CERT: 695940