VMware vSphere Update Manager Java Vulnerability (VMSA-2015-0003)

Medium Nessus Plugin ID 83184


The remote host has an update manager installed that is affected by a Java Runtime Environment (JRE) vulnerability.


The version of VMware vSphere Update Manager installed on the remote Windows host is 5.0 prior to Update 3d, 5.1 prior to Update 3a, 5.5 prior to Update 2e, or 6.0 prior to 6.0.0a. It is, therefore, affected by a vulnerability related to the bundled version of Oracle JRE prior to 1.7.0_76. A flaw exists in the JSSE component due to improper ChangeCipherSpec tracking during SSL/TLS handshakes. This can be exploited by a man-in-the-middle attacker to cause an unencrypted connection to be established.

Note that the application was formerly named vCenter Update Manager.


Upgrade vSphere Update Manager to 5.0 Update 3d / 5.1 Update 3a / 5.5 Update 2e / 6.0.0a or later.

See Also






Plugin Details

Severity: Medium

ID: 83184

File Name: vmware_vcenter_update_mgr_vmsa-2015-0003.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2015/05/01

Modified: 2015/05/04

Dependencies: 66908

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_update_manager, cpe:/a:vmware:vsphere_update_manager

Required KB Items: installed_sw/VMware vCenter Update Manager

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/04/30

Vulnerability Publication Date: 2015/01/20

Reference Information

CVE: CVE-2014-6593

BID: 72169

OSVDB: 117238

VMSA: 2015-0003