Debian DLA-215-1 : libjson-ruby security update

high Nessus Plugin ID 83167

Synopsis

The remote Debian host is missing a security update.

Description

The JSON gem for Ruby allowed remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka 'Unsafe Object Creation Vulnerability.'

For Debian 6 'Squeeze', this issue has been fixed in libjson-ruby version 1.1.9-1+deb6u1.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2015/04/msg00029.html

https://packages.debian.org/source/squeeze-lts/libjson-ruby

Plugin Details

Severity: High

ID: 83167

File Name: debian_DLA-215.nasl

Version: 2.7

Type: local

Agent: unix

Published: 5/1/2015

Updated: 1/11/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:edit-json, p-cpe:/a:debian:debian_linux:libjson-ruby, p-cpe:/a:debian:debian_linux:libjson-ruby-doc, p-cpe:/a:debian:debian_linux:libjson-ruby1.8, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 4/30/2015

Reference Information

CVE: CVE-2013-0269

BID: 57899