Juniper Junos SRX Series Dynamic VPN XSS (JSA10677)

Medium Nessus Plugin ID 82797


The remote device is missing a vendor-supplied security patch.


According to its self-reported version number, the remote Juniper Junos SRX series device is affected by a cross-site scripting vulnerability due to a flaw in Dynamic VPN. A remote attacker can exploit this to view sensitive information or session credentials.

Note that this issue only affects Junos devices with Dynamic VPN enabled.


Apply the relevant Junos software release or workaround referenced in Juniper advisory JSA10677.

See Also

Plugin Details

Severity: Medium

ID: 82797

File Name: juniper_jsa10677.nasl

Version: 1.8

Type: combined

Published: 2015/04/15

Modified: 2017/05/16

Dependencies: 55932

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:juniper:junos

Required KB Items: Host/Juniper/JUNOS/Version, Host/Juniper/model

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/04/08

Vulnerability Publication Date: 2015/04/08

Reference Information

CVE: CVE-2015-3005

BID: 74016

OSVDB: 120482

JSA: JSA10677