Mandriva Linux Security Advisory : libtasn1 (MDVSA-2015:193)

critical Nessus Plugin ID 82617
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Updated libtasn1 packages fix security vulnerability :

The libtasn1 library before version 4.4 is vulnerable to a two-byte stack overflow in asn1_der_decoding (CVE-2015-2806).

Solution

Update the affected lib64tasn1-devel, lib64tasn1_6 and / or libtasn1-tools packages.

See Also

http://advisories.mageia.org/MGASA-2015-0128.html

Plugin Details

Severity: Critical

ID: 82617

File Name: mandriva_MDVSA-2015-193.nasl

Version: 1.5

Type: local

Published: 4/7/2015

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64tasn1-devel, p-cpe:/a:mandriva:linux:lib64tasn1_6, p-cpe:/a:mandriva:linux:libtasn1-tools, cpe:/o:mandriva:business_server:1, cpe:/o:mandriva:business_server:2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 4/7/2015

Reference Information

CVE: CVE-2015-2806

MDVSA: 2015:193