Firefox ESR 31.x < 31.6 Multiple Vulnerabilities

High Nessus Plugin ID 82502


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The version of Firefox ESR 31.x installed on the remote Windows host is prior to 31.6. It is, therefore, affected by the following vulnerabilities :

- A privilege escalation vulnerability exists which relates to anchor navigation. A remote attacker can exploit this to bypass same-origin policy protections, allowing a possible execution of arbitrary scripts in a privileged context. Note that this is a variant of CVE-2015-0818 that was fixed in Firefox ESR 31.5.3.

- Access to certain privileged internal methods is retained when navigating from windows created to contain privileged UI content to unprivileged pages. An attacker can exploit this to execute arbitrary JavaScript with elevated privileges. (CVE-2015-0802)

- A cross-site request forgery (XSRF) vulnerability exists in the sendBeacon() function due to cross-origin resource sharing (CORS) requests following 30x redirections. (CVE-2015-0807)

- Multiple memory safety issues exist within the browser engine. A remote attacker can exploit these to corrupt memory and possibly execute arbitrary code.

- A privilege escalation vulnerability exists related to documents loaded through a 'resource:' URL. An attacker can exploit this to load pages and execute JavaScript with elevated privileges. (CVE-2015-0816)


Upgrade to Firefox ESR 31.6 or later.

See Also

Plugin Details

Severity: High

ID: 82502

File Name: mozilla_firefox_31_6_esr.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2015/04/01

Modified: 2016/05/16

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox_esr

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/31

Vulnerability Publication Date: 2015/01/12

Exploitable With

Metasploit (Firefox PDF.js Privileged Javascript Injection)

Reference Information

CVE: CVE-2015-0801, CVE-2015-0802, CVE-2015-0807, CVE-2015-0815, CVE-2015-0816

BID: 73454, 73455, 73457, 73461, 73466

OSVDB: 119753, 120077, 120078, 120079, 120101, 120106, 120107