Mandriva Linux Security Advisory : phpmyadmin (MDVSA-2015:186)

Medium Nessus Plugin ID 82486


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been discovered and corrected in phpmyadmin :

libraries/select_lang.lib.php in phpMyAdmin 4.0.x before, 4.2.x before, and 4.3.x before includes invalid language values in unknown-language error responses that contain a CSRF token and may be sent with HTTP compression, which makes it easier for remote attackers to conduct a BREACH attack and determine this token via a series of crafted requests (CVE-2015-2206).

This upgrade provides the latest phpmyadmin version ( to address this vulnerability.

Additionally, the phpseclib package has been upgraded to the 0.3.10 version.


Update the affected phpmyadmin and / or phpseclib packages.

See Also

Plugin Details

Severity: Medium

ID: 82486

File Name: mandriva_MDVSA-2015-186.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/04/01

Modified: 2015/04/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:phpmyadmin, p-cpe:/a:mandriva:linux:phpseclib, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/31

Reference Information

CVE: CVE-2015-2206

BID: 72949

MDVSA: 2015:186