Mandriva Linux Security Advisory : git (MDVSA-2015:169)

High Nessus Plugin ID 82422


The remote Mandriva Linux host is missing one or more security updates.


Updated git packages fix security vulnerability :

It was reported that git, when used as a client on a case-insensitive filesystem, could allow the overwrite of the .git/config file when the client performed a git pull. Because git permitted committing .Git/config (or any case variation), on the pull this would replace the user's .git/config. If this malicious config file contained defined external commands (such as for invoking and editor or an external diff utility) it could allow for the execution of arbitrary code with the privileges of the user running the git client (CVE-2014-9390).


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 82422

File Name: mandriva_MDVSA-2015-169.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/03/30

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:git, p-cpe:/a:mandriva:linux:git-arch, p-cpe:/a:mandriva:linux:git-core, p-cpe:/a:mandriva:linux:git-core-oldies, p-cpe:/a:mandriva:linux:git-cvs, p-cpe:/a:mandriva:linux:git-email, p-cpe:/a:mandriva:linux:git-prompt, p-cpe:/a:mandriva:linux:git-svn, p-cpe:/a:mandriva:linux:gitk, p-cpe:/a:mandriva:linux:gitview, p-cpe:/a:mandriva:linux:gitweb, p-cpe:/a:mandriva:linux:lib64git-devel, p-cpe:/a:mandriva:linux:perl-Git, cpe:/o:mandriva:business_server:2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/30

Exploitable With

Core Impact

Metasploit (Malicious Git and Mercurial HTTP Server For CVE-2014-9390)

Reference Information

CVE: CVE-2014-9390

MDVSA: 2015:169