Mandriva Linux Security Advisory : gnupg (MDVSA-2015:154)

Medium Nessus Plugin ID 82407


The remote Mandriva Linux host is missing one or more security updates.


Updated gnupg, gnupg2 and libgcrypt packages fix security vulnerabilities :

GnuPG versions before 1.4.17 and 2.0.24 are vulnerable to a denial of service which can be caused by garbled compressed data packets which may put gpg into an infinite loop (CVE-2014-4617).

The libgcrypt library before version 1.5.4 is vulnerable to an ELGAMAL side-channel attack (CVE-2014-5270).

GnuPG before 1.4.19 is vulnerable to a side-channel attack which can potentially lead to an information leak (CVE-2014-3591).

GnuPG before 1.4.19 is vulnerable to a side-channel attack on data-dependent timing variations in modular exponentiation, which can potentially lead to an information leak (CVE-2015-0837).

The gnupg and gnupg2 package has been patched to correct these issues.

GnuPG2 is vulnerable to these issues through the libgcrypt library.
The issues were fixed in libgcrypt 1.6.3. The libgcrypt package in Mandriva, at version 1.5.4, was only vulnerable to the CVE-2014-3591 issue. It has also been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 82407

File Name: mandriva_MDVSA-2015-154.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/03/30

Modified: 2015/03/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnupg, p-cpe:/a:mandriva:linux:gnupg2, p-cpe:/a:mandriva:linux:lib64gcrypt-devel, p-cpe:/a:mandriva:linux:lib64gcrypt11, cpe:/o:mandriva:business_server:2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2015/03/29

Reference Information

CVE: CVE-2014-3591, CVE-2014-4617, CVE-2014-5270, CVE-2015-0837

MDVSA: 2015:154