Mandriva Linux Security Advisory : mpfr (MDVSA-2015:143)

High Nessus Plugin ID 82396


The remote Mandriva Linux host is missing one or more security updates.


Updated mpfr packages fix security vulnerability :

A buffer overflow was reported in mpfr. This is due to incorrect GMP documentation for mpn_set_str about the size of a buffer (CVE-2014-9474).


Update the affected lib64mpfr-devel, lib64mpfr-static-devel and / or lib64mpfr4 packages.

See Also

Plugin Details

Severity: High

ID: 82396

File Name: mandriva_MDVSA-2015-143.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/03/30

Modified: 2015/03/30

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64mpfr-devel, p-cpe:/a:mandriva:linux:lib64mpfr-static-devel, p-cpe:/a:mandriva:linux:lib64mpfr4, cpe:/o:mandriva:business_server:2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2015/03/29

Reference Information

CVE: CVE-2014-9474

MDVSA: 2015:143