Debian DLA-154-1 : nss security update (BEAST)

High Nessus Plugin ID 82137

Synopsis

The remote Debian host is missing a security update.

Description

nss 3.12.8-1+squeeze11 fixes two security issues :

CVE-2011-3389

SSL 3.0 and TLS 1.0 connections were vulnerable to some chosen plaintext attacks which allowed man-in-the middle attackers to obtain plaintext HTTP headers on an HTTPS session. This issue is known as the 'BEAST' attack.

CVE-2014-1569

Possible information leak with too-permissive ASN.1 DER decoding of length.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2015/02/msg00008.html

https://packages.debian.org/source/squeeze-lts/nss

Plugin Details

Severity: High

ID: 82137

File Name: debian_DLA-154.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2015/03/26

Updated: 2018/07/06

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libnss3-1d, p-cpe:/a:debian:debian_linux:libnss3-1d-dbg, p-cpe:/a:debian:debian_linux:libnss3-dev, p-cpe:/a:debian:debian_linux:libnss3-tools, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/02/16

Reference Information

CVE: CVE-2011-3389, CVE-2014-1569

BID: 49388, 49778, 71675