Debian DLA-117-1 : qt4-x11 security update

High Nessus Plugin ID 82100

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2011-3193

Check for buffer overflow in Lookup_MarkMarkPos that may cause crash in this function with certain fonts.

CVE-2011-3194

Fix tiff reader to handle TIFFTAG_SAMPLESPERPIXEL for grayscale images. The reader uses QImage::Format_Indexed8, but since the samples per pixel value this should be (non-existent) QImage::Format_Indexed16, causing memory corruption. The fix falls back to the 'normal' way of reading tiff images.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2014/12/msg00019.html

https://packages.debian.org/source/squeeze-lts/qt4-x11

Plugin Details

Severity: High

ID: 82100

File Name: debian_DLA-117.nasl

Version: Revision: 1.2

Type: local

Agent: unix

Published: 2015/03/26

Updated: 2015/12/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libqt4-assistant, p-cpe:/a:debian:debian_linux:libqt4-core, p-cpe:/a:debian:debian_linux:libqt4-dbg, p-cpe:/a:debian:debian_linux:libqt4-dbus, p-cpe:/a:debian:debian_linux:libqt4-designer, p-cpe:/a:debian:debian_linux:libqt4-dev, p-cpe:/a:debian:debian_linux:libqt4-gui, p-cpe:/a:debian:debian_linux:libqt4-help, p-cpe:/a:debian:debian_linux:libqt4-multimedia, p-cpe:/a:debian:debian_linux:libqt4-network, p-cpe:/a:debian:debian_linux:libqt4-opengl, p-cpe:/a:debian:debian_linux:libqt4-opengl-dev, p-cpe:/a:debian:debian_linux:libqt4-phonon, p-cpe:/a:debian:debian_linux:libqt4-qt3support, p-cpe:/a:debian:debian_linux:libqt4-script, p-cpe:/a:debian:debian_linux:libqt4-scripttools, p-cpe:/a:debian:debian_linux:libqt4-sql, p-cpe:/a:debian:debian_linux:libqt4-sql-ibase, p-cpe:/a:debian:debian_linux:libqt4-sql-mysql, p-cpe:/a:debian:debian_linux:libqt4-sql-odbc, p-cpe:/a:debian:debian_linux:libqt4-sql-psql, p-cpe:/a:debian:debian_linux:libqt4-sql-sqlite, p-cpe:/a:debian:debian_linux:libqt4-sql-sqlite2, p-cpe:/a:debian:debian_linux:libqt4-sql-tds, p-cpe:/a:debian:debian_linux:libqt4-svg, p-cpe:/a:debian:debian_linux:libqt4-test, p-cpe:/a:debian:debian_linux:libqt4-webkit, p-cpe:/a:debian:debian_linux:libqt4-webkit-dbg, p-cpe:/a:debian:debian_linux:libqt4-xml, p-cpe:/a:debian:debian_linux:libqt4-xmlpatterns, p-cpe:/a:debian:debian_linux:libqt4-xmlpatterns-dbg, p-cpe:/a:debian:debian_linux:libqtcore4, p-cpe:/a:debian:debian_linux:libqtgui4, p-cpe:/a:debian:debian_linux:qt4-demos, p-cpe:/a:debian:debian_linux:qt4-demos-dbg, p-cpe:/a:debian:debian_linux:qt4-designer, p-cpe:/a:debian:debian_linux:qt4-dev-tools, p-cpe:/a:debian:debian_linux:qt4-doc, p-cpe:/a:debian:debian_linux:qt4-doc-html, p-cpe:/a:debian:debian_linux:qt4-qmake, p-cpe:/a:debian:debian_linux:qt4-qtconfig, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/21

Reference Information

CVE: CVE-2011-3193, CVE-2011-3194

BID: 49723, 49724