Debian DLA-105-1 : graphviz security update

high Nessus Plugin ID 82089

Synopsis

The remote Debian host is missing a security update.

Description

Joshua Rogers discovered a format string vulnerability in the yyerror function in lib/cgraph/scan.l in Graphviz, a rich set of graph drawing tools. An attacker could use this flaw to cause graphviz to crash or possibly execute arbitrary code.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2014/12/msg00008.html

https://packages.debian.org/source/squeeze-lts/graphviz

Plugin Details

Severity: High

ID: 82089

File Name: debian_DLA-105.nasl

Version: 1.7

Type: local

Agent: unix

Published: 3/26/2015

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:graphviz, p-cpe:/a:debian:debian_linux:graphviz-dev, p-cpe:/a:debian:debian_linux:graphviz-doc, p-cpe:/a:debian:debian_linux:libcdt4, p-cpe:/a:debian:debian_linux:libcgraph5, p-cpe:/a:debian:debian_linux:libgraph4, p-cpe:/a:debian:debian_linux:libgraphviz-dev, p-cpe:/a:debian:debian_linux:libgv-guile, p-cpe:/a:debian:debian_linux:libgv-lua, p-cpe:/a:debian:debian_linux:libgv-ocaml, p-cpe:/a:debian:debian_linux:libgv-perl, p-cpe:/a:debian:debian_linux:libgv-php5, p-cpe:/a:debian:debian_linux:libgv-python, p-cpe:/a:debian:debian_linux:libgv-ruby, p-cpe:/a:debian:debian_linux:libgv-tcl, p-cpe:/a:debian:debian_linux:libgvc5, p-cpe:/a:debian:debian_linux:libgvc5-plugins-gtk, p-cpe:/a:debian:debian_linux:libgvpr1, p-cpe:/a:debian:debian_linux:libpathplan4, p-cpe:/a:debian:debian_linux:libxdot4, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/11/2014

Reference Information

CVE: CVE-2014-9157

BID: 71283