GLSA-201503-10 : Python: Multiple vulnerabilities

High Nessus Plugin ID 82009


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201503-10 (Python: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.
Impact :

A context-dependent attacker may be able to execute arbitrary code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Python 3.3 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/python-3.3.5-r1' All Python 2.7 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/python-2.7.9-r1'

See Also

Plugin Details

Severity: High

ID: 82009

File Name: gentoo_GLSA-201503-10.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2015/03/24

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:python, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/18

Reference Information

CVE: CVE-2013-1752, CVE-2013-7338, CVE-2014-1912, CVE-2014-2667, CVE-2014-4616, CVE-2014-7185, CVE-2014-9365

GLSA: 201503-10