GLSA-201503-08 : file: Denial of Service

Medium Nessus Plugin ID 82007


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201503-08 (file: Denial of Service)

Multiple issues with the ELF parser used by the file utility have been detected and fixed.
Impact :

A context-dependent attacker can cause Denial of Service.
Workaround :

There is no known workaround at this time.


All file users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/file-5.22'

See Also

Plugin Details

Severity: Medium

ID: 82007

File Name: gentoo_GLSA-201503-08.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/03/24

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:file, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/16

Reference Information

CVE: CVE-2014-2270, CVE-2014-9620, CVE-2014-9621

BID: 66002, 71714, 71715

GLSA: 201503-08