GLSA-201503-07 : hivex: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 82006


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201503-07 (hivex: User-assisted execution of arbitrary code)

Manipulating a short or truncated hive file may trigger an out-of-bounds read or write in hivex.
Impact :

A context-dependent attacker could cause an application linked against hivex to pass a short or truncated hive file, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All hivex users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-misc/hivex-1.3.11'

See Also

Plugin Details

Severity: Medium

ID: 82006

File Name: gentoo_GLSA-201503-07.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/03/24

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:hivex, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/03/14

Reference Information

CVE: CVE-2014-9273

BID: 71279

GLSA: 201503-07