Mac OS X : Cisco AnyConnect Secure Mobility Client < 3.1.10010.0 / 4.0.x < 4.0.4014.0 / 4.1.x < 4.1.4011.0 Code Execution Vulnerability

High Nessus Plugin ID 81979


The remote host is affected by a code execution vulnerability.


The Cisco AnyConnect Secure Mobility Client installed on the remote Mac OS X host is a version prior to 3.1.10010.0, or is version 4.0.x prior to 4.0.4014.0, or version 4.1.x prior to 4.1.4011.0. It is, therefore, affected by a flaw that allows unauthenticated IPC commands to install software as root. A local attacker, by sending a specially crafted IPC command, can exploit this to execute arbitrary programs with elevated privileges.


Upgrade to Cisco AnyConnect Secure Mobility Client version 3.1.10010.0 / 4.0.4014.0 / 4.1.4011.0 or later

See Also

Plugin Details

Severity: High

ID: 81979

File Name: macosx_cisco_anyconnect_4_0_0051.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2015/03/20

Modified: 2017/05/16

Dependencies: 59822

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:cisco:anyconnect_secure_mobility_client

Required KB Items: installed_sw/Cisco AnyConnect Secure Mobility Client, Host/MacOSX/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/07/27

Vulnerability Publication Date: 2015/03/14

Reference Information

CVE: CVE-2015-0662

BID: 73123

OSVDB: 119609