HP ArcSight Logger < 6.0P1 Multiple Vulnerabilities

High Nessus Plugin ID 81976


A log collection and management system on the remote host has multiple vulnerabilities.


According to its self-reported version number, the version of HP ArcSight Logger installed on the remote host is prior to 6.0P1. It is, therefore, affected by the following vulnerabilities :

- An XXE injection vulnerability exists due to the improper verification of sources. An authenticated, remote attacker, using specially crafted XML data, can exploit this to execute scripts on the host with the application's level of privileges.

- A flaw exists due to the improper validation of user-uploaded file names when uploading files via the configuration import file upload capability. An authenticated, remote attacker can exploit this to execute arbitrary PHP scripts on the server.

- A flaw exists due to improper permissions on the Content Management import/export features. An authenticated, remote attacker can exploit this to modify the sources and parsers.


Upgrade to ArcSight Logger 6.0P1 or later.

See Also


Plugin Details

Severity: High

ID: 81976

File Name: arcsight_logger_6_0_1.nasl

Version: $Revision: 1.7 $

Type: local

Family: Misc.

Published: 2015/03/20

Modified: 2016/12/21

Dependencies: 69446

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hp:arcsight_logger

Required KB Items: installed_sw/ArcSight Logger

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/03/11

Vulnerability Publication Date: 2015/03/11

Reference Information

CVE: CVE-2014-7884

BID: 73071

OSVDB: 119489, 119695, 119696

CERT: 868948

HP: HPSBGN03249, emr_na-c04562193, SSRT101697