Mandriva Linux Security Advisory : cups (MDVSA-2015:049)

Medium Nessus Plugin ID 81932


The remote Mandriva Linux host is missing one or more security updates.


Updated cups packages fix security vulnerability :

A malformed file with an invalid page header and compressed raster data can trigger a buffer overflow in cupsRasterReadPixels (CVE-2014-9679).


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 81932

File Name: mandriva_MDVSA-2015-049.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2015/03/19

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:cups, p-cpe:/a:mandriva:linux:cups-common, p-cpe:/a:mandriva:linux:cups-serial, p-cpe:/a:mandriva:linux:lib64cups2, p-cpe:/a:mandriva:linux:lib64cups2-devel, p-cpe:/a:mandriva:linux:php-cups, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2015/03/02

Reference Information

CVE: CVE-2014-9679

MDVSA: 2015:049