Debian DSA-3196-1 : file - security update

High Nessus Plugin ID 81927

Synopsis

The remote Debian host is missing a security-related update.

Description

Hanno Boeck discovered that file's ELF parser is suspectible to denial of service.

Solution

Upgrade the file packages.

For the stable distribution (wheezy), this problem has been fixed in version 5.11-2+deb7u8.

For the upcoming stable distribution (jessie), this problem has been fixed in version 1:5.22+15-1.

See Also

https://packages.debian.org/source/wheezy/file

https://www.debian.org/security/2015/dsa-3196

Plugin Details

Severity: High

ID: 81927

File Name: debian_DSA-3196.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2015/03/19

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:file, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/03/18

Reference Information

CVE: CVE-2014-9653

DSA: 3196