Amazon Linux AMI : postgresql92 (ALAS-2015-492)

High Nessus Plugin ID 81828

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

A buffer overflow flaw was found in the way PostgreSQL handled certain numeric formatting. An authenticated database user could use a specially crafted timestamp formatting template to cause PostgreSQL to crash or, under certain conditions, execute arbitrary code with the permissions of the user running PostgreSQL. (CVE-2015-0241)

A buffer overflow flaw was found in the PostgreSQL's internal printf() implementation. An authenticated database user could use a specially crafted string in a SQL query to cause PostgreSQL to crash or, potentially, lead to privilege escalation. (CVE-2015-0242)

A stack-buffer overflow flaw was found in PostgreSQL's pgcrypto module. An authenticated database user could use this flaw to cause PostgreSQL to crash or, potentially, execute arbitrary code with the permissions of the user running PostgreSQL. (CVE-2015-0243)

A flaw was found in way PostgreSQL handled certain errors during that were generated during protocol synchronization. An authenticated database user could use this flaw to inject queries into an existing connection. (CVE-2015-0244)

The 'make check' command for the test suites in PostgreSQL 9.3.3 and earlier does not properly invoke initdb to specify the authentication requirements for a database cluster to be used for the tests, which allows local users to gain privileges by leveraging access to this cluster. (CVE-2014-0067)

An information leak flaw was found in the way certain the PostgreSQL database server handled certain error messages. An authenticated database user could possibly obtain the results of a query they did not have privileges to execute by observing the constraint violation error messages produced when the query was executed. (CVE-2014-8161)

Solution

Run 'yum update postgresql92' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2015-492.html

Plugin Details

Severity: High

ID: 81828

File Name: ala_ALAS-2015-492.nasl

Version: 1.6

Type: local

Agent: unix

Published: 2015/03/17

Updated: 2020/02/03

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql92, p-cpe:/a:amazon:linux:postgresql92-contrib, p-cpe:/a:amazon:linux:postgresql92-debuginfo, p-cpe:/a:amazon:linux:postgresql92-devel, p-cpe:/a:amazon:linux:postgresql92-docs, p-cpe:/a:amazon:linux:postgresql92-libs, p-cpe:/a:amazon:linux:postgresql92-plperl, p-cpe:/a:amazon:linux:postgresql92-plpython, p-cpe:/a:amazon:linux:postgresql92-pltcl, p-cpe:/a:amazon:linux:postgresql92-server, p-cpe:/a:amazon:linux:postgresql92-server-compat, p-cpe:/a:amazon:linux:postgresql92-test, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2015/03/13

Vulnerability Publication Date: 2014/03/31

Reference Information

CVE: CVE-2014-0067, CVE-2014-8161, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244

ALAS: 2015-492