IBM WebSphere Application Server 7.0 < Fix Pack 37 Multiple Vulnerabilities (POODLE)

Medium Nessus Plugin ID 81825


The remote application server is affected by multiple vulnerabilities.


The IBM WebSphere Application Server running on the remote host is version 7.0 prior to Fix Pack 37. It is, therefore, affected by the following vulnerabilities :

- A man-in-the-middle (MitM) information disclosure vulnerability known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. (CVE-2014-3566 / PI27101)

- An input validation error exists related to session input using URL rewriting that can allow cross-site scripting attacks. (CVE-2014-6167 / PI23819)

- An error exists related to the administrative console that can allow 'click-jacking' attacks.
(CVE-2014-6174 / PI27152)

- Multiple errors exist in the bundled IBM Java SDK. These errors are corrected by the October 2014 IBM Java SDK updates. (CVE-2014-6457, CVE-2014-6512, CVE-2014-6558 / PI27101)

- Multiple errors exist in the bundled IBM Java SDK. These errors are corrected by the January 2015 IBM Java SDK updates. (CVE-2014-6593, CVE-2015-0400, CVE-2015-0410) / PI33407


Apply Fix Pack 37 ( or later.

Note that interim fixes are available. Refer to the vendor security advisory for interim fix identifiers.

See Also

Plugin Details

Severity: Medium

ID: 81825

File Name: websphere_7_0_0_37.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2015/03/17

Modified: 2016/05/24

Dependencies: 57034

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/03/13

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566, CVE-2014-6167, CVE-2014-6174, CVE-2014-6457, CVE-2014-6512, CVE-2014-6558, CVE-2014-6593, CVE-2015-0400, CVE-2015-0410

BID: 70239, 70538, 70544, 70567, 70574, 71850, 72159, 72165, 72169

OSVDB: 99712, 113251, 113333, 113337, 116078, 116079, 117236, 117238, 117239

CERT: 577193