Mac OS X Multiple Vulnerabilities (Security Update 2015-002)

Critical Nessus Plugin ID 81730


The remote host is missing a Mac OS X update that fixes multiple security issues.


The remote host is running a version of Mac OS X 10.8, 10.9, or 10.10 that does not have Security Update 2015-002 applied. This update contains several security-related fixes for the following components :

- iCloud Keychain
- IOAcceleratorFamily
- IOSurface
- mach_port_kobject kernel interface
- Secure Transport

Note that successful exploitation of the most serious of these issues can result in arbitrary code execution.


Install Security Update 2015-002 or later.

See Also

Plugin Details

Severity: Critical

ID: 81730

File Name: macosx_SecUpd2015-002.nasl

Version: $Revision: 1.12 $

Type: local

Agent: macosx

Published: 2015/03/10

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/o:apple:mac_os_x

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, Host/MacOSX/packages/boms

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/09

Vulnerability Publication Date: 2015/01/27

Reference Information

CVE: CVE-2014-4496, CVE-2015-1061, CVE-2015-1065, CVE-2015-1066, CVE-2015-1067

BID: 72334, 73001, 73007

OSVDB: 117638, 119281, 119322, 119323, 119329

APPLE-SA: APPLE-SA-2015-03-09-3