GLSA-201503-03 : PHP: Multiple vulnerabilities

High Nessus Plugin ID 81688

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201503-03 (PHP: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker can leverage these vulnerabilities to execute arbitrary code or cause Denial of Service.
Workaround :

There is no known workaround at this time.

Solution

All PHP 5.5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.5.21' All PHP 5.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.4.37' All PHP 5.3 users should upgrade to the latest version. This branch is currently past the end of life and it will no longer receive security fixes. All PHP 5.3 users are strongly recommended to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.

See Also

https://security.gentoo.org/glsa/201503-03

Plugin Details

Severity: High

ID: 81688

File Name: gentoo_GLSA-201503-03.nasl

Version: 1.13

Type: local

Published: 2015/03/09

Updated: 2018/12/05

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/03/08

Reference Information

CVE: CVE-2014-3710, CVE-2014-8142, CVE-2014-9425, CVE-2014-9427, CVE-2015-0231, CVE-2015-0232

BID: 70807, 71791, 71800, 71833, 72539, 72541

GLSA: 201503-03