Wireshark 1.10.x < 1.10.13 / 1.12.x < 1.12.4 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 81672


The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.


The version of Wireshark installed remote Windows host is 1.10.x prior to 1.10.13, or 1.12.x prior to 1.12.4. It is, therefore, affected by denial of service vulnerabilities in the following items :

- ATN-CPDLC dissector (CVE-2015-2187)
- WCP dissector (CVE-2015-2188)
- pcapng file parser (CVE-2015-2189)
- LLDP dissector (CVE-2015-2190)
- TNEF dissector (CVE-2015-2191)
- SCSI OSD dissector (CVE-2015-2192)

A remote attacker can exploit these vulnerabilities to cause Wireshark to crash or consume excessive CPU resources, either by injecting a specially crafted packet onto the wire or by convincing a user to read a malformed packet trace or PCAP file.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Wireshark version 1.12.4 or later.

See Also








Plugin Details

Severity: Medium

ID: 81672

File Name: wireshark_1_12_4.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2015/03/06

Modified: 2015/05/24

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: installed_sw/Wireshark

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/03/04

Vulnerability Publication Date: 2015/03/04

Reference Information

CVE: CVE-2015-2187, CVE-2015-2188, CVE-2015-2189, CVE-2015-2190, CVE-2015-2191, CVE-2015-2192

BID: 72937, 72938, 72940, 72941, 72942