PuTTY < 0.64 Multiple Information Disclosure Vulnerabilities

Medium Nessus Plugin ID 81669


The remote Windows host has an SSH client that is affected by multiple information disclosure vulnerabilities.


The remote host has a version of PuTTY installed that is prior to 0.64. It is, therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to a failure to clear SSH-2 private key information from the memory during the saving or loading of key files to disk. A local attacker can exploit this to disclose potentially sensitive information. (CVE-2015-2157)

- An information disclose vulnerability exists in the Diffie-Hellman Key Exchange due to a failure to properly handle 0 value keys sent by the server. A man-in-the-middle attacker can exploit this to disclose potentially sensitive information. (VulnDB 136167)


Upgrade to PuTTY version 0.64 or later.

See Also




Plugin Details

Severity: Medium

ID: 81669

File Name: putty_064.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2015/03/06

Modified: 2016/06/20

Dependencies: 57364

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:simon_tatham:putty

Required KB Items: installed_sw/PuTTY

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/02/28

Vulnerability Publication Date: 2015/02/28

Reference Information

CVE: CVE-2015-2157

BID: 72825

OSVDB: 118932, 136167