Cacti < 0.8.6f Multiple Vulnerabilities

high Nessus Plugin ID 81602


The remote web server is running a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the Cacti application running on the remote web server is prior to version 0.8.6f. It is, therefore, potentially affected by the following vulnerabilities :

- Multiple vulnerabilities exist due to improper input validation in 'graph_image.php' and 'graph.php'.

- A flaw exists in 'config.php' that allows remote attackers to set the 'no_http_headers' switch and then modify session information in order to gain the privileges necessary to perform SQL injection attacks.


Upgrade to Cacti 0.8.6f or later.

See Also

Plugin Details

Severity: High

ID: 81602

File Name: cacti_086f_vcheck.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 3/3/2015

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:cacti:cacti

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/cacti

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 7/1/2005

Vulnerability Publication Date: 7/2/2005

Reference Information

CVE: CVE-2005-2148, CVE-2005-2149

BID: 14027, 14130