GLSA-201502-14 : grep: Denial of Service

Low Nessus Plugin ID 81535


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201502-14 (grep: Denial of Service)

A heap buffer overrun has been fixed in the bmexec_trans function in kwset.c.
Impact :

A local user can cause Denial of Service.
Workaround :

There is no known workaround at this time.


All grep users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/grep-2.21-r1'

See Also

Plugin Details

Severity: Low

ID: 81535

File Name: gentoo_GLSA-201502-14.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2015/02/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Temporal Score: 1.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:grep, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/02/25

Reference Information

CVE: CVE-2015-1345

BID: 72281

GLSA: 201502-14