Debian DSA-3169-1 : eglibc - security update

High Nessus Plugin ID 81448

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been fixed in eglibc, Debian's version of the GNU C library :

- CVE-2012-3406 The vfprintf function in stdio-common/vfprintf.c in GNU C Library (aka glibc) 2.5, 2.12, and probably other versions does not 'properly restrict the use of' the alloca function when allocating the SPECS array, which allows context-dependent attackers to bypass the FORTIFY_SOURCE format-string protection mechanism and cause a denial of service (crash) or possibly execute arbitrary code via a crafted format string using positional parameters and a large number of format specifiers, a different vulnerability than CVE-2012-3404 and CVE-2012-3405.

- CVE-2013-7424 An invalid free flaw was found in glibc's getaddrinfo() function when used with the AI_IDN flag. A remote attacker able to make an application call this function could use this flaw to execute arbitrary code with the permissions of the user running the application. Note that this flaw only affected applications using glibc compiled with libidn support.

- CVE-2014-4043 The posix_spawn_file_actions_addopen function in glibc before 2.20 does not copy its path argument in accordance with the POSIX specification, which allows context-dependent attackers to trigger use-after-free vulnerabilities.

- CVE-2014-9402 The getnetbyname function in glibc 2.21 or earlier will enter an infinite loop if the DNS backend is activated in the system Name Service Switch configuration, and the DNS resolver receives a positive answer while processing the network name.

- CVE-2015-1472 / CVE-2015-1473 Under certain conditions wscanf can allocate too little memory for the to-be-scanned arguments and overflow the allocated buffer. The incorrect use of '__libc_use_alloca (newsize)' caused a different (and weaker) policy to be enforced which could allow a denial of service attack.

Solution

Upgrade the eglibc packages.

For the stable distribution (wheezy), these issues are fixed in version 2.13-38+deb7u8 of the eglibc package.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681888

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=751774

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775572

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777197

https://security-tracker.debian.org/tracker/CVE-2012-3406

https://security-tracker.debian.org/tracker/CVE-2012-3404

https://security-tracker.debian.org/tracker/CVE-2012-3405

https://security-tracker.debian.org/tracker/CVE-2013-7424

https://security-tracker.debian.org/tracker/CVE-2014-4043

https://security-tracker.debian.org/tracker/CVE-2014-9402

https://security-tracker.debian.org/tracker/CVE-2015-1472

https://security-tracker.debian.org/tracker/CVE-2015-1473

https://packages.debian.org/source/wheezy/eglibc

https://www.debian.org/security/2015/dsa-3169

Plugin Details

Severity: High

ID: 81448

File Name: debian_DSA-3169.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2015/02/24

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:eglibc, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/02/23

Reference Information

CVE: CVE-2012-3406, CVE-2013-7424, CVE-2014-4043, CVE-2014-9402, CVE-2015-1472, CVE-2015-1473

BID: 54374, 68006, 71670, 72428, 72499, 72710

DSA: 3169