Apache ActiveMQ 5.x < 5.10.1 / 5.11.0 Multiple Vulnerabilities

High Nessus Plugin ID 81374

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote host has a web application installed that is affected by multiple vulnerabilities.

Description

The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.10.1 / 5.11.0. It is, therefore, potentially affected by multiple vulnerabilities :

- An unauthenticated, remote attacker can crash the broker listener by sending a packet to the same port that a message consumer or product connects to, resulting in a denial of service condition. (CVE-2014-3576)

- An XML external entity (XXE) injection vulnerability exists that is related to XPath selectors. A remote attacker can exploit this, via specially crafted XML data, to disclose the contents of arbitrary files.
(CVE-2014-3600)

- A flaw exists in the LDAPLoginModule of the Java Authentication and Authorization Service (JAAS) which can be triggered by the use of wildcard operators instead of a username or by invalid passwords. A remote attacker can exploit this to bypass authentication.
(CVE-2014-3612)

- Multiple cross-site scripting (XSS) vulnerabilities exist in the web administrative console. (CVE-2014-8110)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to version 5.10.1 / 5.11.0 or later.

See Also

http://www.nessus.org/u?c8309341

http://www.nessus.org/u?b3d4e09f

http://www.nessus.org/u?3b2b5313

Plugin Details

Severity: High

ID: 81374

File Name: activemq_5_10_1.nasl

Version: 1.13

Type: remote

Family: CGI abuses

Published: 2015/02/16

Updated: 2019/11/25

Dependencies: 45552

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2014-3612

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/ActiveMQ, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/22

Vulnerability Publication Date: 2010/04/06

Reference Information

CVE: CVE-2014-3576, CVE-2014-3600, CVE-2014-3612, CVE-2014-8110

BID: 72510, 72511, 72513