GLSA-201502-04 : MediaWiki: Multiple vulnerabilities

High Nessus Plugin ID 81227


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201502-04 (MediaWiki: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in MediaWiki. Please review the CVE identifiers and MediaWiki announcement referenced below for details.
Impact :

A remote attacker may be able to execute arbitrary code with the privileges of the process, create a Denial of Service condition, obtain sensitive information, bypass security restrictions, and inject arbitrary web script or HTML.
Workaround :

There is no known workaround at this time.


All MediaWiki 1.23 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.23.8' All MediaWiki 1.22 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.22.15' All MediaWiki 1.19 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.19.23'

See Also

Plugin Details

Severity: High

ID: 81227

File Name: gentoo_GLSA-201502-04.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2015/02/09

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mediawiki, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/02/07

Exploitable With

Core Impact

Metasploit (MediaWiki Thumb.php Remote Command Execution)

Elliot (MediaWiki thumb.php page Parameter Remote Shell Command Injection)

Reference Information

CVE: CVE-2013-6451, CVE-2013-6452, CVE-2013-6453, CVE-2013-6454, CVE-2013-6472, CVE-2014-1610, CVE-2014-2242, CVE-2014-2243, CVE-2014-2244, CVE-2014-2665, CVE-2014-2853, CVE-2014-5241, CVE-2014-5242, CVE-2014-5243, CVE-2014-7199, CVE-2014-7295, CVE-2014-9276, CVE-2014-9277, CVE-2014-9475, CVE-2014-9476, CVE-2014-9477, CVE-2014-9478, CVE-2014-9479, CVE-2014-9480, CVE-2014-9481, CVE-2014-9487, CVE-2014-9507

GLSA: 201502-04